Author Topic: L4D1+2 Tickrate Enabler 1.3  (Read 177319 times)

Sir

  • *
  • Posts: 919
    • View Profile
Re: L4D1+2 Tickrate Enabler 1.3
« Reply #405 on: June 24, 2017, 04:12:32 am »
On some maps after the change of level (switching to the next map), the server crashes with this error. The server crash exactly when the map is switched and the new map has not even started to load:Fall server is not always. Sometimes the levels are changing without falling. Only on map c1m3_mall (It is very often), c2m3_coaster, c5m4_quarter, c7m2_barge (Rarely). Server coop.

In this case, all the players who played on the server, hangs the loading.

This occurs only when tickrate increase with more than 30. I have 60 tickrate. Maybe there are ways to solve the problem with this error?

vCPU 2x3.0Ghz Intel, RAM 4Gb, SSD 30Gb

This isn't caused by the tickrate enabler itself, a simple google search reveals it's related to memory issues (Enough dedicated ram per server?)
If in any case it was related to the tickrate enabler (or a too high setting) it would've been noticed in the competitive scene as the standard is 100 Tick.
Group Owner of :| SirPlease
Config Dev :| Zonemod 1.8

strelok74

  • *
  • Posts: 5
    • View Profile
Re: L4D1+2 Tickrate Enabler 1.3
« Reply #406 on: June 24, 2017, 04:15:51 am »
At 30 tickrates, there is no such mistake :)
This error occurs only on the servers Coop, on the Versus this does not happen, even with elevated tickrates.
Can there be any settings to allow the server to use more RAM?
On the server I have a full 4GB.
« Last Edit: June 24, 2017, 04:26:45 am by strelok74 »

Froxoxo

  • *
  • Posts: 2
    • View Profile
Re: L4D1+2 Tickrate Enabler 1.3
« Reply #407 on: February 01, 2018, 08:52:58 am »
So i had no problems with the 3 first releases, until we had to update because of valve's update braking this plugin, i noticed now the 1.4 tickrate enabler posted by SirPlease (with or without tickratefixes the same problem occurs) that the Overkill campaign final is broken, once you enter the subway you instantly die and restart the level, while the game stay in slow motion.

It was on a fresh L4D2 dedi server with no other plugins.

I finaly found after many hours that it was due to this plugin (tickrate enabler 1.4).


Also about net_splitrate and net_splitpacket_maxrate here https://github.com/SirPlease/Server4Dead-Project/tree/master/Tickrate%20Enabler SirPlease says if you run 128 tick then you need to set to tickx1000 so for 128 tick = 128000.

Here he says to set to 64000. https://www.l4dnation.com/confogl-and-other-configs/l4d12-tickrate-enabler-1-0/msg49658/#msg49658

i dont know what net_splitrate does neither splitpacket_maxrate.

Also here https://www.l4dnation.com/confogl-and-other-configs/l4d12-tickrate-enabler-1-0/msg35313/#msg35313 say This is usually enough to remove lags. Note that it's for the client, not for the server, and works best if placed in the autoexec.

net_maxroutable "1280"
net_splitrate "2"
net_splitpacket_maxrate "30000"

Not sure what this mean.

hope this helps. Good luck
« Last Edit: February 01, 2018, 11:08:34 am by Froxoxo »

 

A dedicated community website to competitive L4D and L4D2, ran by the community, for the community. L4DNation supports all continents of play and focuses on bringing together the community as a whole to a central hub of information.